Instalar PHP-GTK 2 en Linux

Llevo ya bastante tiempo utilizando PHP-GTK 2 para hacer alguna que otra aplicación. En Windows me va de maravilla, ya que tienes Gnope que es autoinstalable y es de agradecer porque las primeras versiones de PHP-GTK 1 para mi eran un infierno. Otra alternativa son las últimas versiones compiladas de PHP-GTK para Windows, ya que es copiar y pegar, no hay que hacer nada para hacerlas correr.

Al dar el paso de Linux me encontre con un problema, y es que por mas que buscara, no había o no encontraba ningún paquete instalable de PHP-GTK. Buscando por internet veia como todo el mundo que lo utilizaba simpelemente hacia un:

  ./configure
  make
  make install

Al intentarlo yo, ingenuo de mi por ver la facilidad con que lo hacia el resto de la gente, lo intente, y lo único que consegui fue una consola llena de errores por todos lados.

Como me paso al compilar Wine, pense que podría ser que necesitara los sources de las diferentes librerias que quería instalar. Fui en busca de Synaptic e instale los paquetes dev de Gtk, SourceView, Mozilla Firefox, GtkHtml, GtkExtra, GtkExtra y LibSexy.

Una vez tengamos instalados todos estos paquetes dev (para el desarrollo), procedi a un configure completo, copilarlo e instalarlo.

  ./configure --enable-php-gtk --with-extra --with-html
     --with-libsexy --with-mozembed --with-sourceview
     --with-spell
  make
  make install

Aparte de esto, me aventure a crear mi primer paquete .deb que he hecho nunca, que a pesar de ser muy chapucero, al menos instala php-gtk en el sistema y funciona perfectamente, salvo por unas modificaciones de configuración que debemos de realizar a manita. Por si alguien se quiere ahorrar compilarlo, se puede descargar el paquete .deb de php-gtk 2.

Para finalizar la instalación deberemos de activar el modulo en el php.ini. En mi instalación de PHP, no hay un php.ini global, sino que hay uno pequeño y muchos, uno por cada extensión. Yo lo he creado donde las extensiones, creando un nuevo archivo que he llamado gtk.ini, pero podeis ponerlo en el php.ini principal. Lo unico que deberemos de hacer es añadir la linea:

  extension=php_gtk2.so

A continuación os detallo las librerias que se pueden encontrar con la instalación de PHP-GTK.

  • Gtk: todos los componentes básicos de Gtk, tales como GtkWindow por ejemplo, por decirlo de alguna manera, es lo básico para crear cualquier aplicación.
  • LibSexy: no lo he probado y me baso solo en la teoría que he visto por la web. Se trata de clases especiales para poner iconos en los GtkEntry, corrección ortografica, etc. (las pijerias).
  • GtkHtml: es un motor de renderización de HTML. El HTML lo pinta bien, pero los enlaces no funcionan, supongo que habrá que programar todos los posibles eventos que puedan surgir.
  • GtkExtra: tampoco lo he podido probar, pero supuestamente da Widget extra como los GtkSheet al estilo excel o algunos de diseño lineal que creo que no estan incluidos en PHP-GTK.
  • MozEmbed: se supone que es el motor de renderizado de HTML de Gecko (el de Mozilla Firefox), pero no he conseguido hacerlo funcionar ya que me da un error en el nucleo de GTK, que creo que es debido a que necesita unas cuantas librerias que utiliza el propio Firefox para que funcione.
  • SourceView: es una parte bastante interesante de Gtk, ya que se trata de un Widget que hereda directamente de GtkTextView pero que provee de un coloreado de sintaxis para multitud de lenguajes de programación, incluidos por supuesto PHP, C#, C, Java, Ruby, Xml, etc. Tambien provee de algunas mejoras al GtkTextView como una regla para marcar el número de linea o algunos eventos como el coloreado de la llave enlazada por ejemplo cuando es una función o clase. Este modulo funciona a la perfección.
  • GtkSpell: un corrector ortografico que subralla de una linea roja las palabras mal escritas. Lo he probado y funciona a la perfección, supongo que tendra soporte de lenguajes.

Si alguien quiere ver algo más de información sobre el tema, que le eche un vistazo a la página del proyecto PHP-GTK.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *